手機版
官方微信
掃描關注:理想財富微信公眾號
RSS

求助好心人看看MACD頂底背離自動畫線副圖指標【通達信】的公式錯在什么地方

[通達信]
設置
33100 26 漫2010 Lv.4 發表于 · 2015-6-7 22:48 舉報 只看樓主 復制 倒序瀏覽 |
跳轉到指定樓層
網上找到的看貼圖貌似不錯,可是我的通達信裝不上,不知道錯在哪里,有那位好心人幫忙解決,謝謝
MACD頂底背離自動畫線副圖指標【通達信】
{MACD背離劃線
SHORT 5 40 12
LONG 10 100 26
M 2 40 9}
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD:=2*(DIFF-DEA);
Zero : 0;
gj:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,2,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,2,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2,0),color00ff00;
L4:=LLV(gj,4);
jl:=(HHV(diff,55)-LLV(diff,55))/5;
gt:=dea>REF(dea,1) AND REF(dea,1)<REF(dea,2);
A1:=BARSLAST(REF(gt,1));
底背離:=REF(L4,A1+1)>CLOSE AND diff>REF(diff,A1+1) AND gt;
DRAWLINE(A1=0,DEA,底背離,REF(DEA,A1),0),colorred,LINETHICK2;
DRAWLINE(底背離,DEA,底背離,REF(DEA,A1),0),colorred,LINETHICK2;
DRAWTEXT(底背離,REF(DEA,A1)*1.18,' 底背離'),COLORFF00FF;
H4:=HHV(gj,4);
gt2:=dea<REF(dea,1) AND REF(dea,1)>REF(dea,2);
A2:=BARSLAST(REF(gt2,1));
頂背離:= REF(H4,A2+1)<H4 AND diff<REF(diff,A2+1) AND gt2;
DRAWLINE(A2=0 ,DEA,頂背離,REF(DEA,A2),0),colorgreen,LINETHICK2;
DRAWLINE(頂背離,DEA,頂背離,REF(DEA,A2),0),colorgreen,LINETHICK2;
DRAWTEXT(頂背離,REF(DEA,A2)*1.18,' 頂背離'),colorgreen;

舉報

扔雞蛋(0) 回復

鬼舞十七
Lv.4
發表于 2015-6-7 23:46 復制 2樓 只看該作者
公式沒錯,將下面  SHORT :   5 40 12     LONG:   10 100 26      M:  2 40 9  三個參數分別填上即可。


DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD:=2*(DIFF-DEA);
Zero : 0;
gj:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,2,0),color0000ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,2,0),colorffff00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,0),colorff00ff;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2,0),color00ff00;
L4:=LLV(gj,4);
jl:=(HHV(diff,55)-LLV(diff,55))/5;
gt:=dea>REF(dea,1) AND REF(dea,1)<REF(dea,2);
A1:=BARSLAST(REF(gt,1));
底背離:=REF(L4,A1+1)>CLOSE AND diff>REF(diff,A1+1) AND gt;
DRAWLINE(A1=0,DEA,底背離,REF(DEA,A1),0),colorred,LINETHICK2;
DRAWLINE(底背離,DEA,底背離,REF(DEA,A1),0),colorred,LINETHICK2;
DRAWTEXT(底背離,REF(DEA,A1)*1.18,' 底背離'),COLORFF00FF;
H4:=HHV(gj,4);
gt2:=dea<REF(dea,1) AND REF(dea,1)>REF(dea,2);
A2:=BARSLAST(REF(gt2,1));
頂背離:= REF(H4,A2+1)<H4 AND diff<REF(diff,A2+1) AND gt2;
DRAWLINE(A2=0 ,DEA,頂背離,REF(DEA,A2),0),colorgreen,LINETHICK2;
DRAWLINE(頂背離,DEA,頂背離,REF(DEA,A2),0),colorgreen,LINETHICK2;
DRAWTEXT(頂背離,REF(DEA,A2)*1.18,' 頂背離'),colorgreen; @漫2010

舉報

點亮(0) 扔雞蛋(0) 回復

漫2010
Lv.4
發表于 2015-6-8 06:44 復制 3樓 只看該作者
謝謝鬼舞十七老師,問題已解決,祝鬼舞十七老師投資順利。同時感謝理想論壇給了小散免費分享技術,數據的平臺。

舉報

點亮(0) 扔雞蛋(0) 回復

漫2010
Lv.4
發表于 2015-6-13 17:23 復制 4樓 只看該作者
怎么好的公式,這么多的人瀏覽,沒有一個人給我評論,加分,汗,看樣子是我的人品不好。

舉報

點亮(0) 扔雞蛋(0) 回復

酷得這么無奈
Lv.1
發表于 2015-8-12 03:30 復制 5樓 只看該作者
原帖由 @漫2010 于 2015-6-13 17:23 發表
怎么好的公式,這么多的人瀏覽,沒有一個人給我評論,加分,汗,看樣子是我的人品不好。

不太會弄啊

舉報

扔雞蛋(0) 回復

知我罪我
Lv.3
發表于 2015-9-17 12:23 復制 6樓 只看該作者
@鬼舞十七 當前公式 : 背離 (指標畫線公式)  
錯誤句 : DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG)
詳細信息 : 未知字符串 SHORT
錯誤起始位置 : 17 ; 長度: 5
乍回事,老師!

舉報

點亮(0) 扔雞蛋(0) 回復

鬼舞十七
Lv.4
發表于 2015-9-17 14:32 復制 7樓 只看該作者
SHORT :   5 40 12     LONG:   10 100 26      M:  2 40 9  三個參數分別填上@知我罪我

舉報

點亮(0) 扔雞蛋(0) 回復

知我罪我
Lv.3
發表于 2015-9-17 15:55 復制 8樓 只看該作者
@鬼舞十七 填寫在哪里呀?

舉報

點亮(0) 扔雞蛋(0) 回復

鬼舞十七
Lv.4
發表于 2015-9-17 22:06 復制 9樓 只看該作者
打開公式管理器 參數的地方填上以上數據 @知我罪我

舉報

點亮(0) 扔雞蛋(0) 回復

糾結帝
Lv.1
發表于 2015-12-13 12:35 復制 10樓 只看該作者
我按照這個復制粘貼 為什么出來
當前公式 : MACD頂底背離 (指標畫線公式)  
錯誤句 :
?:= REF(H4,A2+1)<H4 AND DIFF<REF(DIFF,A2+1) AND GT2
詳細信息 : 變量 ? 定義重復!
錯誤起始位置 : 783 ; 長度: 8
請教一下怎么弄呢?

舉報

點亮(0) 扔雞蛋(0) 回復

現代金屬
Lv.3
發表于 2016-1-10 14:32 復制 11樓 只看該作者
看圖    對你有用的話   請給我加分

[ 本帖最后由 現代金屬 于 2016-1-10 14:34 編輯 ]

舉報

點亮(0) 扔雞蛋(0) 回復

現代金屬
Lv.3
發表于 2016-1-10 14:43 復制 12樓 只看該作者
MACD畫背離.tne (7.63 KB, 下載次數: 121) MACD背離自動畫線   




效果圖

[ 本帖最后由 現代金屬 于 2016-1-10 14:46 編輯 ]

附件

捕獲3333.JPG

65.73 KB, 下載次數: 3

捕獲3333.JPG

舉報

點亮(0) 扔雞蛋(0) 回復

藍天游
Lv.1
發表于 2016-5-2 19:08 復制 14樓 只看該作者
新手沒有幣不可以下載,怎么樣才可以下載啊

舉報

扔雞蛋(0) 回復

萊科寧00
Lv.2
發表于 2016-12-1 13:58 復制 16樓 只看該作者
you yong

舉報

扔雞蛋(0) 回復

萊科寧00
Lv.2
發表于 2016-12-1 14:00 復制 18樓 只看該作者
不錯有用啊 可與啊

舉報

扔雞蛋(0) 回復

柳櫻
Lv.1
發表于 2016-12-10 16:41 復制 19樓 只看該作者
感謝老師分享

舉報

扔雞蛋(0) 回復

吹風007
Lv.3
發表于 2017-1-17 00:50 復制 20樓 只看該作者
感謝老師分享
謝謝

舉報

扔雞蛋(0) 回復

股海浮升
Lv.1
發表于 2017-2-16 18:15 復制 21樓 只看該作者
老師給的指標里面有未來函數

舉報

扔雞蛋(0) 回復

樂活股神
Lv.2
發表于 2017-10-4 01:34 復制 22樓 只看該作者
底背離自動畫線副

舉報

扔雞蛋(0) 回復

熊大人兒
Lv.2
發表于 2018-1-29 20:10 復制 24樓 只看該作者
可惜,是畫金叉死叉的背離線,不是畫DIF的背離線,畫背離現在還得自己動手 @現代金屬

舉報

點亮(0) 扔雞蛋(0) 回復

理想707a65
Lv.0
發表于 2018-2-24 19:50 復制 25樓 只看該作者

舉報

扔雞蛋(0) 回復

徐小白XX
Lv.2
發表于 2020-3-25 12:50 復制 26樓 只看該作者
不準確,蠻多背離都沒有畫出來

舉報

扔雞蛋(0) 回復

您需要登錄后才可以回帖

本版積分規則

論壇問題
微信掃一掃,添加好友咨詢
驛站問題
微信掃一掃,添加好友咨詢
廣告投放
微信掃一掃,添加好友咨詢
回頂部 到頁底
快速回復 返回頂部 返回列表
重庆快3-官网 上海快3-欢迎您 北京快3-安全购彩 湖北快3-Welcome 湖南快3-Home 河北快3-安徽快3 河南快3-推荐 广东快3-官网 广西快3-欢迎您 吉林快3-安全购彩