手機版
官方微信
掃描關注:理想財富微信公眾號
RSS

請老師幫忙把下面指標改成通達信機構參與很強的預警公式

[通達信]
設置
4014 5 鏵哥 Lv.1 發表于 · 2020-5-27 12:52 舉報 只看樓主 復制 倒序瀏覽 |
跳轉到指定樓層
麻煩各位大哥大姐了,改成機構參與力度很強預警,紫色柱子表示很強,黃色表示強,代碼如下

A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交額:=V*C/100,NODRAW;{萬元}
A2:=SUM((IF(((成交額/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交額,0)),0);
A3:=SUM((IF(((成交額/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交額,0)),0);
A4:=SUM((IF(((成交額/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交額,0)),0);
A5:=SUM((IF(((成交額/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交額,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
增減倉%:A1;
機構買:(A2),LINETHICK6,COLORRED;
機構賣:(A3),LINETHICK6,COLORFFFF55;
機構進出:機構買-機構賣,NODRAW;
散戶買:(A4),COLOR5555FF;{細紅線}
散戶賣:(A5),COLOR55FF55;{細綠線}
強勢:((100*A2)/A6>50);
STICKLINE(強勢,機構買*1.02,機構買*1.1,1,0),COLORYELLOW;
拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,機構買*1.1,機構買*1.2,1,0),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1,機構買*0.95,'●機構買'),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR=1,機構賣*0.95,'○機構賣'),LINETHICK2,COLORFFFF55;
DRAWTEXT(機構進出>0 AND REF(機構進出,1)<=0,機構買*1.02,'●機買'),COLORRED;
DRAWTEXT(機構進出<0 AND REF(機構進出,1)>=0,機構買*0.98,'○機賣'),COLORFFFF55;

舉報

扔雞蛋(0) 回復

休閑者68
Lv.6
發表于 2020-5-27 13:04 復制 2樓 只看該作者
成交額:=V*C/100;
A2:=SUM((IF(((成交額/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交額,0)),0);
A3:=SUM((IF(((成交額/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交額,0)),0);
A4:=SUM((IF(((成交額/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交額,0)),0);
A5:=SUM((IF(((成交額/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交額,0)),0);
A6:=((A2+A3)+A4)+A5;
機構買:=(A2);
拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;

舉報

點亮(0) 扔雞蛋(0) 回復

鏵哥
Lv.1
發表于 2020-5-27 13:49 復制 3樓 只看該作者
休閑者68 發表于 2020-5-27 13:04
成交額:=V*C/100;
A2:=SUM((IF(((成交額/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交額,0)),0);
A3:=SUM((IF ...

謝謝,我去試試,辛苦了老師

舉報

扔雞蛋(0) 回復

哈小羅
Lv.2
發表于 2020-5-27 15:08 復制 4樓 只看該作者
感謝提供學習資料~~

舉報

扔雞蛋(0) 回復

青青江岸
Lv.2
發表于 2020-5-31 14:49 復制 5樓 只看該作者
謝謝分享               

舉報

扔雞蛋(0) 回復

風1962
Lv.2
發表于 2020-6-13 16:17 復制 6樓 只看該作者
鏵哥 發表于 2020-5-27 13:49
謝謝,我去試試,辛苦了老師

你的這個指標反映太過遲鈍,發出信號時,個股已經上漲了30% --- 40%,追漲容易被套,建議還是換個指標吧

附件

指標1.jpg

576.75 KB, 下載次數: 0

指標1.jpg

指標2.jpg

488 KB, 下載次數: 2

指標2.jpg

舉報

點亮(0) 扔雞蛋(0) 回復

您需要登錄后才可以回帖

本版積分規則 《免責聲明》

論壇問題
微信掃一掃,添加好友咨詢
驛站問題
微信掃一掃,添加好友咨詢
廣告投放
微信掃一掃,添加好友咨詢
回頂部 到頁底
快速回復 返回頂部 返回列表
重庆快3-官网 上海快3-欢迎您 北京快3-安全购彩 湖北快3-Welcome 湖南快3-Home 河北快3-安徽快3 河南快3-推荐 广东快3-官网 广西快3-欢迎您 吉林快3-安全购彩