手機版
官方微信
掃描關注:理想財富微信公眾號
RSS

老師請幫忙去掉圖中的K線

[通達信]
設置
1064 3 雨竹168 Lv.3 發表于 · 2020-7-1 09:41 舉報 只看樓主 復制 倒序瀏覽 |
跳轉到指定樓層
老師請幫忙去掉圖中的K線、底背離、成立、看跌,保留均線等其余指標

AAF:LLV(LOW,34),LINETHICK1,COLORFFFFCC;
BBF:MA(AAF,4),LINETHICK1,COLORYELLOW;
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短線:VAR1,COLORWHITE;
中線:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
TJ1:= CCI1>差值4;
立樁量:=FILTER(TJ1,0),NODRAW;
TJ2:=IF(BARSLAST(立樁量)=1 ,1,0);
STICKLINE(立樁量 !=1,REF(HIGH,BARSLAST(立樁量)),
REF(HIGH,BARSLAST(立樁量)),1,1),COLORCYAN;
{STICKLINE(立樁量 !=1,REF(LOW,BARSLAST(立樁量)),
REF(LOW,BARSLAST(立樁量)),1,1),COLORCYAN;}
成立1:=TJ2=1;
條件成立1:=FILTER(成立1,5);
DRAWTEXT(條件成立1, REF(HIGH,BARSLAST(立樁量)),'看跌'),COLORLIBLUE;
TJ11:= CCI1<-差值4 ;
立樁量2:=FILTER(TJ11,0),NODRAW;
TJ22:=IF(BARSLAST(立樁量2)=1 AND CLOSE>REF(HIGH,1),1,0);
突破2:=TJ22=1;
{STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立樁量2)),
REF(HIGH,BARSLAST(立樁量2)),1,1),COLORYELLOW;}
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立樁量2)),
REF(LOW,BARSLAST(立樁量2)),1,1),COLORYELLOW;
TJ:=IF(BARSLAST(立樁量2)=1 AND CLOSE>REF(LOW,1),1,0);
成立2:=TJ=1;
條件成立2:=FILTER(成立2,5);
DRAWTEXT(條件成立2,REF(LOW,BARSLAST(立樁量2)),'看漲'),COLORLIMAGENTA;
TJ111:=ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5);
立樁量3:=FILTER(TJ111,3);
TJ3:=IF(BARSLAST(立樁量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立樁量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立樁量3)=3 AND CLOSE>REF(LOW,3),1,0)));
成立:=TJ3=1;
條件成立:=FILTER(成立,5);
DRAWTEXT(條件成立 AND 下跌!= VAR6,L*0.97,'☆成立');
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),BBF,'底背離'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'頂背離'),COLOR1880FF;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45'),COLORWHITE;

STICKLINE(1,C,O,2.8,0),COLOR666600;
STICKLINE(立樁量,C,O,2.8,0),COLOR0000FF;
STICKLINE(1,C,O,0,0),COLORCCCCCC;
AA:=IF((CLOSE < 100),CLOSE,(CLOSE / 100));
A:=INTPART(((4 * (LOG(AA) / LOG(2))) + 1));
B:=((A - 1) / 4);
支撐:IF((CLOSE > 100),(POW(2,B) * 100),POW(2,B)),CIRCLEDOT,LINETHICK1,COLORBROWN;
壓力:IF((CLOSE > 100),(POW(2,(B + (1 / 4))) * 100),POW(2,(B + (1 / 4)))),CIRCLEDOT,LINETHICK1,COLORFF5500;
DRAWICON(REF(壓力,1)=支撐,L*0.95,1);
{DRAWICON(支撐>HHV(H,15),H*1.05,2);};
DRAWTEXT(ISLASTBAR,支撐,'----支撐'),COLOR00AAFF;
DRAWTEXT(ISLASTBAR,壓力,'----壓力'),COLORFF5500;

舉報

扔雞蛋(0) 回復

許昌舍得
Lv.6
發表于 2020-7-1 11:36 復制 2樓 只看該作者
AAF:LLV(LOW,34),LINETHICK1,COLORFFFFCC;
BBF:MA(AAF,4),LINETHICK1,COLORYELLOW;
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短線:VAR1,COLORWHITE;
中線:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
TJ1:= CCI1>差值4;
立樁量:=FILTER(TJ1,0),NODRAW;
TJ2:=IF(BARSLAST(立樁量)=1 ,1,0);
STICKLINE(立樁量 !=1,REF(HIGH,BARSLAST(立樁量)),
REF(HIGH,BARSLAST(立樁量)),1,1),COLORCYAN;
{STICKLINE(立樁量 !=1,REF(LOW,BARSLAST(立樁量)),
REF(LOW,BARSLAST(立樁量)),1,1),COLORCYAN;}
成立1:=TJ2=1;
條件成立1:=FILTER(成立1,5);
{DRAWTEXT(條件成立1, REF(HIGH,BARSLAST(立樁量)),'看跌'),COLORLIBLUE;}
TJ11:= CCI1<-差值4 ;
立樁量2:=FILTER(TJ11,0),NODRAW;
TJ22:=IF(BARSLAST(立樁量2)=1 AND CLOSE>REF(HIGH,1),1,0);
突破2:=TJ22=1;
{STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立樁量2)),
REF(HIGH,BARSLAST(立樁量2)),1,1),COLORYELLOW;}
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立樁量2)),
REF(LOW,BARSLAST(立樁量2)),1,1),COLORYELLOW;
TJ:=IF(BARSLAST(立樁量2)=1 AND CLOSE>REF(LOW,1),1,0);
成立2:=TJ=1;
條件成立2:=FILTER(成立2,5);
DRAWTEXT(條件成立2,REF(LOW,BARSLAST(立樁量2)),'看漲'),COLORLIMAGENTA;
TJ111:=ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5);
立樁量3:=FILTER(TJ111,3);
TJ3:=IF(BARSLAST(立樁量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立樁量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立樁量3)=3 AND CLOSE>REF(LOW,3),1,0)));
成立:=TJ3=1;
條件成立:=FILTER(成立,5);
{DRAWTEXT(條件成立 AND 下跌!= VAR6,L*0.97,'☆成立');}
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
{DRAWTEXT(CROSS(FF,MA15),BBF,'底背離'),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'頂背離'),COLOR1880FF;}
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45'),COLORWHITE;

{STICKLINE(1,C,O,2.8,0),COLOR666600;
STICKLINE(立樁量,C,O,2.8,0),COLOR0000FF;
STICKLINE(1,C,O,0,0),COLORCCCCCC;}
AA:=IF((CLOSE < 100),CLOSE,(CLOSE / 100));
A:=INTPART(((4 * (LOG(AA) / LOG(2))) + 1));
B:=((A - 1) / 4);
支撐:IF((CLOSE > 100),(POW(2,B) * 100),POW(2,B)),CIRCLEDOT,LINETHICK1,COLORBROWN;
壓力:IF((CLOSE > 100),(POW(2,(B + (1 / 4))) * 100),POW(2,(B + (1 / 4)))),CIRCLEDOT,LINETHICK1,COLORFF5500;
DRAWICON(REF(壓力,1)=支撐,L*0.95,1);
{DRAWICON(支撐>HHV(H,15),H*1.05,2);};
DRAWTEXT(ISLASTBAR,支撐,'----支撐'),COLOR00AAFF;
DRAWTEXT(ISLASTBAR,壓力,'----壓力'),COLORFF5500;

附件

tdxjietu2.JPG

395.77 KB, 下載次數: 0

tdxjietu2.JPG
查看全部打賞
  • 福阿德+8理想幣 +7共享幣 : 理想精神:分享,互助,友善,傳遞正能量!

舉報

點亮(1) 扔雞蛋(0) 回復

休閑者68
Lv.6
發表于 2020-7-1 11:37 復制 3樓 只看該作者
AAF:LLV(LOW,34),LINETHICK1,COLORFFFFCC;
BBF:MA(AAF,4),LINETHICK1,COLORYELLOW;
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短線:VAR1,COLORWHITE;
中線:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
TJ1:= CCI1>差值4;
立樁量:=FILTER(TJ1,0),NODRAW;
TJ2:=IF(BARSLAST(立樁量)=1 ,1,0);
STICKLINE(立樁量 !=1,REF(HIGH,BARSLAST(立樁量)),
REF(HIGH,BARSLAST(立樁量)),1,1),COLORCYAN;
{STICKLINE(立樁量 !=1,REF(LOW,BARSLAST(立樁量)),
REF(LOW,BARSLAST(立樁量)),1,1),COLORCYAN;}
{成立1:=TJ2=1;
條件成立1:=FILTER(成立1,5);
DRAWTEXT(條件成立1, REF(HIGH,BARSLAST(立樁量)),'看跌'),COLORLIBLUE;}
TJ11:= CCI1<-差值4 ;
立樁量2:=FILTER(TJ11,0),NODRAW;
TJ22:=IF(BARSLAST(立樁量2)=1 AND CLOSE>REF(HIGH,1),1,0);
突破2:=TJ22=1;
{STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立樁量2)),
REF(HIGH,BARSLAST(立樁量2)),1,1),COLORYELLOW;}
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立樁量2)),
REF(LOW,BARSLAST(立樁量2)),1,1),COLORYELLOW;
TJ:=IF(BARSLAST(立樁量2)=1 AND CLOSE>REF(LOW,1),1,0);
成立2:=TJ=1;
條件成立2:=FILTER(成立2,5);
DRAWTEXT(條件成立2,REF(LOW,BARSLAST(立樁量2)),'看漲'),COLORLIMAGENTA;
TJ111:=ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5);
立樁量3:=FILTER(TJ111,3);
TJ3:=IF(BARSLAST(立樁量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立樁量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立樁量3)=3 AND CLOSE>REF(LOW,3),1,0)));
{成立:=TJ3=1;
條件成立:=FILTER(成立,5);
DRAWTEXT(條件成立 AND 下跌!= VAR6,L*0.97,'☆成立');}
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
{FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),BBF,'底背離'),COLORA6E500;}
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'頂背離'),COLOR1880FF;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45'),COLORWHITE;

{STICKLINE(1,C,O,2.8,0),COLOR666600;
STICKLINE(立樁量,C,O,2.8,0),COLOR0000FF;
STICKLINE(1,C,O,0,0),COLORCCCCCC;}
AA:=IF((CLOSE < 100),CLOSE,(CLOSE / 100));
A:=INTPART(((4 * (LOG(AA) / LOG(2))) + 1));
B:=((A - 1) / 4);
支撐:IF((CLOSE > 100),(POW(2,B) * 100),POW(2,B)),CIRCLEDOT,LINETHICK1,COLORBROWN;
壓力:IF((CLOSE > 100),(POW(2,(B + (1 / 4))) * 100),POW(2,(B + (1 / 4)))),CIRCLEDOT,LINETHICK1,COLORFF5500;
DRAWICON(REF(壓力,1)=支撐,L*0.95,1);
{DRAWICON(支撐>HHV(H,15),H*1.05,2);};
DRAWTEXT(ISLASTBAR,支撐,'----支撐'),COLOR00AAFF;
DRAWTEXT(ISLASTBAR,壓力,'----壓力'),COLORFF5500;
查看全部打賞
  • 福阿德+8理想幣 +7共享幣 : 理想精神:分享,互助,友善,傳遞正能量!

舉報

點亮(1) 扔雞蛋(0) 回復

雨竹168
Lv.3
發表于 2020-7-1 13:04 復制 4樓 只看該作者
謝謝二位大師

舉報

扔雞蛋(0) 回復

您需要登錄后才可以回帖

本版積分規則 《免責聲明》

論壇問題
微信掃一掃,添加好友咨詢
驛站問題
微信掃一掃,添加好友咨詢
廣告投放
微信掃一掃,添加好友咨詢
回頂部 到頁底
快速回復 返回頂部 返回列表
重庆快3-官网 上海快3-欢迎您 北京快3-安全购彩 湖北快3-Welcome 湖南快3-Home 河北快3-安徽快3 河南快3-推荐 广东快3-官网 广西快3-欢迎您 吉林快3-安全购彩