手機版
官方微信
掃描關注:理想財富微信公眾號
RSS

請老師編寫均線金叉死叉后高低點劃線主圖公式

[通達信]
設置
939 3 歪歪賬號 Lv.2 發表于 · 2020-7-1 12:48 舉報 只看樓主 復制 倒序瀏覽 |
跳轉到指定樓層
要求:
        1.通達信使用
        2.根據5均線與34均線關系編寫(5均線金叉34后的最高點與5均線死叉34均線的最低點自動劃線)
        3.高低點連線中間的K線個數大于等于13根(如果覺得這項有難度,可以忽略,當然我是期待您能搞定)

這里先謝謝老師啦!

舉報

扔雞蛋(0) 回復

歪歪賬號
Lv.2
發表于 2020-7-1 15:43 復制 2樓 只看該作者
以下是我引用另一位老師編寫的指標
這個指標沒有滿足第三點,盼望哪位老師補充一下

X1:MA(C,5);
X2:MA(C,34);
HT:=BARSLAST(X1<X2);
LT:=BARSLAST(X1>X2);
K:=CROSS(X1,X2) OR CROSS(X2,X1) OR ISLASTBAR;
TX:=BARSNEXT(K);
LH:=IF(X1>X2,HHV(H,HT),LLV(L,LT));
HL:=IF(ISLASTBAR,LH,REFX(REFX(REF(LH,1),TX),1));

LH2:=IF(X1>X2,LLV(L,HT),HHV(H,LT));
HL2:=IF(ISLASTBAR,LH2,REFX(REFX(REF(LH2,1),TX),1));
ZXD:=H=HL OR L=HL;
CCC:=IF(H=HL,H,IF(L=HL,L,0));
STICKLINE(HL=REF(HL,1) AND HL2=REF(HL2,1) AND X1>X2,HL,HL2,3,0),COLOR330033;
STICKLINE(HL=REF(HL,1) AND HL2=REF(HL2,1) AND X1<X2,HL,HL2,3,0),COLOR334400;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
X1;X2;
ZX:=PLOYLINE(ZXD,CCC);
DRAWBAND(ZX,RGB(0,180,200),(ZX+REF(ZX,1))/2,RGB(200,200,0));

舉報

扔雞蛋(0) 回復

北沙
Lv.7
發表于 2020-7-2 09:02 復制 3樓 只看該作者
歪歪賬號 發表于 2020-7-1 15:43
以下是我引用另一位老師編寫的指標
這個指標沒有滿足第三點,盼望哪位老師補充一下

M5:MA(C,5);
M34:MA(C,34);
金叉天數:=BARSLAST(CROSS(M5,M34));
起點:=IF(M5>M34,FILTERX(H=HHV(H,金叉天數),金叉天數),0);
死叉天數:=BARSLAST(CROSS(M34,M5));
終點:=IF(M5<M34,FILTERX(L=LLV(L,死叉天數),死叉天數),0) AND BARSLAST(起點)>=13;
連線:DRAWLINE(起點,H,終點,L,0);

舉報

點亮(0) 扔雞蛋(0) 回復

歪歪賬號
Lv.2
發表于 2020-7-2 09:31 復制 4樓 只看該作者
感謝@北沙 老師參與~

舉報

點亮(0) 扔雞蛋(0) 回復

您需要登錄后才可以回帖

本版積分規則 《免責聲明》

論壇問題
微信掃一掃,添加好友咨詢
驛站問題
微信掃一掃,添加好友咨詢
廣告投放
微信掃一掃,添加好友咨詢
回頂部 到頁底
快速回復 返回頂部 返回列表
重庆快3-官网 上海快3-欢迎您 北京快3-安全购彩 湖北快3-Welcome 湖南快3-Home 河北快3-安徽快3 河南快3-推荐 广东快3-官网 广西快3-欢迎您 吉林快3-安全购彩